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How to use this 
administrator’s guide

This administrator’s guide explains how to run My Clients & Profits! X, an add-on web 
server that lets creatives, account executives, and out-of-office staff members access 
the shop’s Clients & Profits X database. This guide provides complete, step-by-step in-
structions for installing, setting up, and running the My Clients & Profits! X software. (A 
separate User Guide explains how web users log onto and use the My Clients & Profits! 
X)

You’ll find many helpful screen shots throughout the administrator’s guide that illustrate 
My Clients & Profits! X’s management features and web capabilities. For more informa-
tion, visit the My C&P! X web site:  

                www.cnp-x.com/my  

There you’ll find up-to-date technical information about how the My Clients & Profits! X 
web server works, as well as tips, shortcuts, and troubleshooting ideas.

Contents

4 Introducing My Clients & Profits! X
5      The My Clients & Profits! X Home Page
6 Quick Start
8 How My Clients & Profits! X Works
10 My Clients & Profits! X Features
12 Setting My Clients & Profits! X Preferences
14 Setting Up My Clients & Profits! X Users
16      Access Privileges
18 Running the My Clients & Profits! X Web Server
19      The My Clients & Profits! X Server Status Window
20 The My Clients & Profits! X Activity Log
22 Printing My Clients & Profits! X Reports
24 Remotely Managing My Clients & Profits! X 
26 Appendix A: Security Issues
28 Index
30 My Clients & Profits! X Web Pages Flow Chart



4

Introducing My Clients & Profits! X

My Clients & Profits! X is an add-on web server for your Clients & Profits 5.x 
database that allows creatives, account executives, and out-of-office staff 
members to track jobs, traffic, time, expenses, and more from anywhere using 
any kind of internet-enabled computer.

The My C&P! X web server serves web pages using real-time data from your 
Clients & Profits database. Users can add proposals, open jobs, edit traffic 
and schedules, review company and personal calendars, update status re-
ports, enter hours on time cards, and track costs using only a web browser—
and more.

My Clients & Profits! X  acts as a 
gateway between the shop’s Clients 
& Profits database and any number 
of users either inside or outside the 
office. A user opens their web browser 
then logs onto the My C&P! X server 
by entering a specified web address 
(such as “http://my.clientsandprofits.
com”), their user ID, and their pass-
word. My C&P! X verifies the user’s 
ID and password, then displays a 
personalized “creative
dashboard,” or home page. This 
home page contains links to the 
various client, job, and costing 
functions available to them, as well 
as links to company and industry 
news, a company calendar, and an 
optional online company handbook.

My Clients & Profits! X maintains its 
own list of web users, so only authorized 
people can use it. Hundreds of users can 
be supported, depending on your server 
hardware. Once connected to the My 
Clients & Profits! X web server,  staff 
members and freelancers can perform 
many creative, production, and account service (but not, for security reasons, 
accounting) activities.

My Clients & Profits! X also lets authorized clients and vendors access their 
information in your database. Clients can see their account information, job 
tickets, client job status report, and invoices. Vendors can see their own pur-
chase orders. Each individual who works at a client or vendor must have his 
or her own My C&P! X web ID and password, which prevents them from see-
ing the work of other clients and vendors. This keeps important data private.

My Clients & Profits! X is available 24/7 (except during nightly backups). It 
runs unattended on a stand-alone computer that is connected to your Clients 
& Profits file server. There is no preset limit on the number of concurrent My 

Introducing My Clients & Profits! X

No password, no access  The 
My C&P! home page requires a 
valid, active user ID and pass-
word before allowing someone 
to access the shop’s database.

C&P! X users, so many web users can add jobs, time, and expenses simulta-
neously. 

The My Clients & Profits! X web server keeps track of every request, or hit, in 
a log. This makes it easy for a web server administrator to track the server’s 
usage, including who’s using it at which times. The web server administrator 
can remotely monitor and manage the My Clients & Profits! X web server 
from home, a hotel room, an airport—anywhere there’s an internet connec-
tion. My Clients & Profits! X even sends instant e-mail error notifications to 
the webmaster. 

All of the My Clients & Profits! X web 
pages are customizable. 
A page’s design can be tailored to 
match your company’s visual identity 
and style. This can make your My 
C&P! X system look and feel just like 
your web site for anyone who uses it.



5

Each My C&P! X web user 
has their own personalized 
home page, whether they are 
a staff member, freelancer, 
client, or vendor.

A special “welcome” 
message greets each 
My C&P! X user on their 
home page. This greeting 
is edited in the user’s 
Access & Privileges 
window by the web server 
administrator.

Clicking on a web 
page’s help link 
opens the My 
C&P! X online 
user guide.

Everyone can track 
their daily hours 
using their time 
card.  It keeps a 
daily record of the 
jobs and tasks on 
which you work. 

The deadlines sec-
tion shows all of 
the staff member’s 
unfinished tasks, 
both due today 
and overdue, from 
the Work To Do 
window.

The company calen-
dar page is linked to 
the Calendar window 
in Clients & Profits, 
listing company 
events, meetings, and 
important dates.

The job hot sheet 
list shows every job 
on which the staff 
member is assigned 
(either as the AE or 
as one of the traffic 
assignments from the 
traffic system. 

The In / Out Board 
shows the status of 
all staff members. 
You can change your 
status by clicking on 
the User Name link.

The My Clients & Profits! X home page

The My Clients & Profits! X Home Page

The In / Out Board 
shows the status of all 
staff members. You can 
change your status by 
clicking on the User 
Name link.
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Quick Start To install the My C&P! X 
web server

The My Clients & Profits! X web server installs like the regular Clients & Prof-
its X software, so the process is probably familiar: Download the My Clients 
& Profits! X installer onto a PC or Mac, start the Installer application, then 
follow the prompts. The My Clients & Profits! X web server can be started 
once its preferences and web users have been set up.

The My Clients & Profits! X web server requires a dedicated Mac Pro, 
Macbook, iMac, or eMac running Mac OS X v10.2 (or later) or a PC running 
Windows 2000/XP, a full-time high-speed connection to the internet, and a 
full-time LAN connection to your Clients & Profits file server. This computer 
must have a fixed IP address that can be accessed outside of the office.  Also, 
this computer should be dedicated to running My C&P! X, so shouldn’t be 
used for other web, mail, or file servers for best performance.

■  For up-to-date system recommendations for My Clients & Profits! X, 
please see www.cnp-x.com/sales/server_recs.html

My Clients & Profits! X should only be installed on the server that will run it. 
The My Clients & Profits! X is fully self-contained. There is nothing to install 
on the user workstations or on the Clients & Profits X file server itself. 

My Clients & Profits! X is browser-independent, meaning anyone using any 
kind of web browser can access the Clients & Profits X database from any 
kind of computer.

■  My Clients & Profits! X only works with Clients & Profits Classic X, Clients 
& Profits Pro X, and Job Tracker X or later databases. If you are using an 
earlier version of Clients & Profits, please call (800) 272-4488 for upgrade 
information.

The Clients & Profits X web site features detailed technical information, 
including up-to-date hardware recommendations:    
   
            www.cnp-x.com/sales/server_recs.html

Before installing My Clients & Prof-
its! X, be sure that the computer 
does not contain any prior versions 
of My Clients & Profits. Different 
versions of C&P can conf lict with 
the My Clients & Profits! X web 
server and cause system problems.

1  Download the My Clients & Prof-
its! X installer from www.cnp-x.com

2  On a Mac, double-click on the 
Installer. On a Windows-based PC 
the installer application starts up 
automatically.

The Installer will prompt you to 
choose a destination for the new 
My Clients & Profits! X folder. On a 
Mac, the Applications folder is se-
lected automatically. In Windows, 
the Programs folder is selected 
automatically. Any volume can be 
chosen.

3  Follow the prompts to finish the 
installation.

A My Clients & Profits! folder will 
be copied to your hard disk. Inside 
it you’ll find the My Clients & Prof-
its! X application, an HTML folder 
that contains the My C&P! web 
pages, and other program files.

4  Restart the computer.

For technical help, please call (800) 521-2166

Activating the My C&P! X 
web server

My Clients & Profits! X needs to 
be activated before it can be used. 
Activation automatically serializes 
your application, which contains 
multi-user access to your database. 
Unless activated, My C&P! X will 
run in a 60-day trial mode.

1  On a Mac, double-click on the 
My C&P! X application. In Win-
dows, choose Start > Programs > 
My Clients & Profits!  

2  Find and open your Clients & 
Profits X database from the file 
server, or connect to your SQL 
database.

3  Enter your Clients & Profits 
X user ID and password when 
prompted.

You must be a Clients & Profits 
X manager-level user to initially 
set up the My Clients & Profits! 
X web server. Once My C&P! X is 
running, access to it is controlled 
by a separate web user list (see “To 
Add My C&P! X web users” on page 
7).  You’ll then see the My C&P! X 
Web Server Status window.  Before 
the web server can be started, the 
server’s preferences (including a 
webmaster’s name and e-mail ad-
dress) and users must be entered.

4  Choose My Clients & Profits! > 
Activate then click the Activate 
button. 

Quick Start
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To add My C&P! X web 
users

1  Choose Setup > Users, Access & 
Passwords.

2  Click the Auto-Create Web Users 
button.

The Auto-Create Web Users window 
opens, listing all of your current 
Clients & Profits users.  

3  Click OK.

Web user accounts are auto-
matically created for everyone who 
currently uses Clients & Profits 
now, using the same password for 
the web server. Later, web access 
privileges and passwords can be 
changed for each user. Once web 
user accounts are created, the My 
Clients & Profits! web server can 
be started.

■  For details about setting up web 
user accounts for My C&P! X, see 
page 18.

To access the My C&P! X 
web server from a web 
browser

1  Open a web browser such as 
Safari, FireFox, or Internet Explorer.

2  Enter the My C&P! X web 
server’s IP address or name, then 
press Enter.

The My C&P! X web server can 
be identified by its IP address or 
by a URL depending on how your 
domain name is configured with 
your ISP or internal DNS server.  An 
IP address would be entered like 
“http://192.168.100.10” while a 
URL could be entered as “http://
my.agency.com”. The URL can be 
any name of your choosing. 

3  Enter your web ID and password, 
then click Go.

If you’re successfully connected 
you’ll see the My Clients & Profits!  
X home page—your “creative 
dashboard” that displays your time 
card, deadlines, job hot sheet, and 
the shop’s in/out board.

To use the various parts of My 
Clients & Profits! X, use the drop-
down menus on the home page.

To set my My C&P! X 
preferences

Before starting the My Clients & 
Profits! X web server, be sure to set 
the server’s basic preferences:

1  Choose My Clients & Profits! > 
Web Server Preferences.

2  Enter or select any of the set-
tings that seem appropriate to 
your web server (see page 17 for a 
description of each preference). 

■  Most web servers use port 80 
by default. However, Mac OS X 
reserves for port 80 for itself, a dif-
ferent port number must be used. 

■  Be sure to enter the My C&P! 
X webmaster’s name, their e-mail 
address, and address of your 
mail server first. This enables 
the  server’s automatic e-mail 
notifications, which keep the web 
administrator constantly informed 
of server problems.

3 Click Save.

■  For details about setting My 
C&P! X preferences, see page 
16-17.

To start the My C&P! X 
web server

1  Choose My Clients & Profits! > 
Start Web Server, or click the Start 
button.

Once started, My Clients & Profits! 
X begins listening for requests from 
web users.  Every request, or hit, 
from a web user makes a log entry 
into the Web Server Status window, 
so it’s easy to monitor who’s using 
the web server.

Quick Start

Starting the web server Buttons to start 
and stop the My Clients & Profits! X web 
server are found in the window’s toolbar.
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How My Clients & Profits! X Works

The My Clients & Profits! X web server acts as a gateway between your 
shop’s Clients & Profits X database and any number of Safari, FireFox, or 
Internet Explorer—whether in the office (your “intranet”), working at home, 
in a client’s conference room, or in a hotel room somewhere on the road. No 
browser plug-ins or special software is needed.

My Clients & Profits! X installs and runs just like the regular Clients & Profits 
software. My C&P! X features an industry-standard HTTP server for publish-
ing custom web pages that include real-time data from the Clients & Profits 
database. Users access My Clients & Profits! X by entering the web server’s 
address, or URL. The URL can be the computer’s actual IP address (e.g., 
192.168.100.55) or a custom domain name (e.g., “my.clientsandprofits.com”). 
In fact, the web address of My C&P! X can be any variation of the shop’s 
domain name. The web server is started by opening the My C&P! X applica-
tion, opening your shop’s C&P X database from the file server, then clicking 
the Start button. Once the My C&P! X web server has been started, it begins 
listening for incoming HTTP requests from web users.

■  Due to limitations in its TCP server engine, SSL is not supported. 

Any web browser can access the My C&P! X web server as long as the user 
has the right access privileges. Only authorized users can access the My 
Clients & Profits! X web server, which share access privileges with the user 
list in Clients & Profits. 

How the web administrator manages My Clients & Profits! X

Only existing C&P system managers can configure the My Clients & Profits! 
X web server, including adding web users. Anyone can be added as a web 
user, including clients, vendors, freelancers, and contractors—all with specific 
access privileges to what they can and can’t see and do. Any web user can 
be a web server administrator and make changes to the My C&P! X server’s 
preferences, monitor the server’s status, and print web server reports. One 
web administrator (typically the Clients & Profits system manager) can be 
designated as the webmaster. The webmaster is the key contact for anything 
My C&P! X-related. The webmaster’s name and e-mail address appears on 
error pages (so that users can contact him or her about problems) and gets 
notified automatically via e-mail about web errors. 

How staffers, freelancers, clients, and vendors will use My Clients & 
Profits! X

From a user’s point-of-view, using My Clients & Profits! X is even simpler. A 
user opens their web browser then logs onto the My C&P! X web server using 
a special URL (e.g., http://my.clientsandprofits.com). An introduce yourself 
page prompts them to enter their user ID and password. My Clients & Profits! 
X instantly verifies the ID and password, then displays a personalized “cre-
ative dashboard” home page.

Introducing My Clients & Profits! X

Staff members and freelancers have full access (within the limits of their 
access privileges, that is) to clients, jobs, time cards, expenses, and purchase 
orders. Clients see their own account information, jobs, and Client Job Status 
Report. Vendors see only their own purchase, insertion, and broadcast orders. 
Web administrators have the same access as staff members, but have links to 
monitor and manage the My Clients & Profits! X web server remotely.

My Clients & Profits! X will let any number of web-based users access the 
shop’s database concurrently. To the database, the My Clients & Profits! X 
web server looks like any other user on the network. 

■  My C&P! X takes up one of the database's user slots (for example, a 10-
user version of Clients & Profits that also uses My C&P! X will have 9 slots 
available for non web-based users). 

Padlocks, error checking

Unlike regular Clients & Profits X users, web users don't have a full-time 
connection to the shop's database. This means they won't get padlocks that 
indicate record-locking, and losing the network connection can't damage the 
database. Instead, each request is a separate transaction that's received by 
the My C&P! X web server, processed, then returned to the web page in the 
form of a web page. Because there is no full-time connection to the Clients & 
Profits database, there is no interactive error-checking when a user tabs from 
field to field. Error checking only occurs when the transaction is saved; if an 
error occurs (such as an invalid job number), the My C&P! X displays an error 
page to the user explaining what was done wrong. 

Performance factors

The performance of the My Clients & Profits! X web server depends on three 
factors: 

(1) the speed of the internet connection, 

(2) the speed of the server running the My C&P! X web server, and 

(3) the amount of traffic on the LAN and the Clients & Profits file server. 

Stress in any of these areas will be noticeable to web users when they 
request a web page or wait for data to be submitted (although data-entry will 
be unaffected). Transactions from My Clients & Profits! X have no greater or 
lesser priority over regular Clients & Profits X users—everything is handled 
first-come, first-serve.
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The My Clients & Profits! X web server acts as a gateway between your shop’s Clients & Profits X database and any number of web-based us-
ers—whether in the office, working at home, at a client location or on the road.

The My Clients & Profits! X Flow Chart

HOW IT WORKS: A user opens their web browser then logs onto the server using the special web address, a personalized ID, and password. My 
Clients & Profits! X verifies the user’s access privileges then displays a personalized “creative dashboard” home page. This page features links 
to the various client, job, and costing functions using drop-down menus.

I N T E R N E TI N T R A N E T

My C&P! X
Web Server

Creative

Account Service

Clients & 
Vendors

Out-of-Office
Staffers

Freelancers

C&P 
SERVER

Accounting

Production

Media
Traffic
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My Clients & Profits! X Features

General

— My Clients & Profits! X is a stand-alone application that runs on a dedi-
cated Mac OS X or Windows based PC; no additional software is needed.
— My Clients & Profits! X can be accessed inside or outside the office using 
any high-speed internet connection.
— My Clients & Profits! X is compatible FireFox and Internet Explorer, but is 
optimized for Safari.
— My C&P! X serves real-time data-driven web pages directly from the C&P 
X database. 
— No browser plug-ins are required.
— Access to My C&P! X is available only to authorized users with their own 
web accounts.
— Each web user has his or her own My C&P! X-specific access privileges that 
piggyback on the user’s regular Clients & Profits access privileges.
— Web accounts can be created for individual clients contacts, giving them 
access to only their own jobs, traffic, and invoices.
— Web accounts can be created for freelancers, allowing them to enter time 
and see work schedules.
— Vendors can be given web accounts to access their purchase orders.
— My C&P! X web pages can be redesigned to fit the shop’s corporate identi-
ty and visual style by any other web design and site management application.
— Additional data fields can be added using special OMFLD database tags.
— A web-based version of the Clients & Profits X In/Out Board lets staff 
members track when they arrive and leave the office.
— Staffers can use My C&P! X to mark themselves unavailable for the day, 
morning or afternoon. 
— My C&P! X web pages have help links to an enhanced online user guide.

Personalized home page

— Each web has his or her own custom “creative dashboard” home page 
that displays their time card, deadlines, job hot sheet, and the agency in/
out board.
— Users access clients, jobs, costs, etc. using drop-down menus that work 
just like those found in Clients & Profits X.
— Web administrators can include a custom log-in message that appears at 
the bottom of the user’s home page.
— Clicking on a date in the home page calendar jumps to that day, display-
ing the user’s time card and deadlines for that date.
— The home page can be customized with text and links to employment 
benefits, policies, standards, and holidays from the company handbook.
— Lookup pages show complete lists of clients, jobs, staff members, vendors, 
status codes, the task table, groups, purchase/insertion/broadcast orders, job 
type/spec sheets, and client projects.
— Real-time access to company and personal calendars. 
— Web users can add calendar entries to the personal and company calendar.

Clients

— The client web page features name, address, contact, and account informa-

tion.
— The client page includes links to client contacts, billing info, budgets, the 
client diary, projects, stats, jobs, and invoices.
— New client diary entries can be added from My C&P! X.
— The Client Jobs page lists a client’s open and closed jobs, including esti-
mate, hours, billed, and unbilled totals.
— The Client Invoices page lists client’s billing history, including unpaid 
invoices.
— New client projects can be added from My Clients & Profits!
— The Lookup Clients page lists all clients; clicking on a client number opens 
the Clients web page directly.
— A client’s contacts can be viewed and edited.

Proposals

— Proposals can be viewed, added, edited, approved, killed and printed.
— Approving a proposal converts it into a new job automatically.

Job Tickets

— The job ticket web page looks just like the Job Ticket window in Clients & 
Profits X, displaying the job’s number, name, contacts, and tasks.
— Users can find jobs by number or use the “Lookup Jobs” page.
— The job ticket web page features links to the job’s specifications, work or-
der, creative brief, estimate, schedule, job snapshot, diary, and change orders.
— Web users can open new jobs using job type/spec sheets.
— Tasks from the Task Table can be added to existing job tickets.
— Web users can edit and print a job’s printing specs, work order, and 
creative brief.
— The start and due dates for a job’s scheduling tasks can be updated.
— New jobs can be opened for any client, based on the user’s access privi-
leges. If a new job is given a job type/spec sheet, My Clients & Profits! X will 
copy the template’s tasks to the new job automatically.
— Estimates can be viewed, edited, and approved or unapproved for any job.
— Printer-friendly estimate previews can be printed for any job. 
— Change orders can be viewed, added, and deleted.
— A job’s production status, billing status, status notes, next steps, traffic 
assignments, and milestones can be updated from the Traffic web page.
— Web users can view the task’s billings, POs, and job costs.
— The Job Snapshot web page shows authorized users a job’s estimate 
remaining, hours worked to date, billings, and profit so far.
— Selected job production and accounting reports, such as the Job Sum-
mary, can be printed. 
— Job tasks can be removed from job tickets.

Production and Traffic

— The Daily Job Status report can be viewed by production status or billing, 
just like the regular report printed from Clients & Profits X. 
— Users with the appropriate access privileges can update a job’s status 
codes and status notes any time.

My Clients & Profits! X Features bold features are new in My Clients & Profits! X
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— The web-based Weekly Traffic report looks like the report printed from 
Clients & Profits X.
— Creatives and production staff can review the week’s deadlines from job 
schedules in their Weekly Task Planner web page any time.
— The web-based Work To Do page lets creative and production staff keep 
track of unfinished job tasks for any range of start dates or due dates.
— The Daily Job Status and Weekly Traffic reports can now show jobs by 
billing status.
— Both clients and staff members can use the web-based Client Job Status 
report to track a client’s open jobs.
— The Job Timeline can be viewed for one job at a time.
— Opened jobs can be tracked using the Production Planner.
— Purchase orders can add, edit, updated, and printed. 
— Users with the right access privileges can approve or unapprove POs.

Job Costing

— Production, creative, and account service staffers can add, edit, and print 
purchase orders.
— Production managers can approve new purchase orders online.*
— Staff members can enter their hours worked on a daily Time Card web 
page.  
— Lookup lists on time cards, POs, and expense reports open up automati-
cally if no job or task is entered onto the time entry.
— Budget alerts can be triggered when adding POs, time, and expenses.
— Time cards have a stopwatch timer to automatically track hours worked.
— Time from previous days can be reviewed and changed as needed, based 
on the user’s access privileges.  
— Staff time sheets can be approved on-line by department managers.
— Production and creative staff working on location can enter time each day, 
keep productivity and job cost reports up-to-the-minute accurate and timely.
— Staff members can enter daily expense reports for travel, parking, in-house 
supplies, and more without manual expense forms.
— Internal charges for items such as CD duplication, output, slides, can be 
added, edited, and removed.
— Vendor invoices can be approved for payment.*

Billing

— Client invoices can be approved for printing.*
— Job estimates can be pre-billed.

Snapshots

— Production snapshot reports can be printed by production status and a 
selected client: Job Hot Sheet, Traffic Hot Sheet, Rush Jobs. 
— Work in progress snapshots can be printed for a range of production or 
billing status codes and a selected client: Billing Hot Sheet, Job Billing 
Worksheets, Unbilled Costs by Job.  

My Clients & Profits! X Features

Administration and security

— No browser plug-ins or special software is needed.
— A Web Server Status window constantly monitors the web server’s current 
activity and its connected users (by IP address), producing a hits-per-hour 
graph. This window makes it easy for webmasters to check the server’s 
performance at a glance.
— My Clients & Profits! X will automatically close then reopen the database 
at selected times to accommodate the nightly backups.
— The web server port 80 can be administrator-defined in Preferences.
— Cookies are used to automatically log in users throughout the day.
— The My Clients & Profits! X can be set to automatically start listening for 
hits every time the application is opened.
— My Clients & Profits! X supports multiple webmasters. 
 — Webmasters can monitor and manage the My C&P! X server remotely from 
home or on the road from any internet connection, including public browsers.
— A My C&P! X webmaster can be notified automatically via e-mail on failed 
attempted log-ins and invalid passwords.
— The server’s activity log can be printed remotely from a web browser.
— Temporary “guest” access is not allowed to prevent access to My C&P! X 
from anonymous web users.
— Web accounts can be automatically created for current Clients & Profits 
users, eliminating rekeying.
— Users cannot create their own web accounts, and cannot choose their own 
passwords (which are required); both are performed by the webmaster.
— Users cannot create their own web accounts, and cannot choose their own 
— All web user accounts require a password.
— Users cannot create their own web accounts, and cannot choose their own 
passwords
— Web accounts can be temporarily suspended for security reasons.
— A web account is automatically suspended after 3 bad login attempts.
— A detailed activity log keeps track of every kind of hit to the My C&P! X 
web server, including each hit’s date, time, user ID, IP address, and event/ac-
tion. 
— The web log can be automatically archived to a text file every Monday.
— Server reports can be printed to analyze the performance and utilization of 
My Clients & Profits! X based on log entries.
— Your company’s logo can appear at the top of each web page by simply 
placing a 179x62 graphic on your web site then entering its URL into the 
server’s preferences.
— Clicking on the company logo jumps to a new web page defined by the 
web administrator in the server’s preferences, such as a company intranet 
page.

* Not available in Clients & Profits Classic X
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Setting My C&P! X Preferences

Key functions of the My Clients & Profits! X web server are controlled by 
the system’s preferences, which are user-defined. My C&P! X web server 
administrators can change these settings and options to improve the server’s 
accountability and security. One or more My C&P! X users who are defined as 
web administrators can change the server’s preferences as needed, anytime.

■  The server’s preferences can’t be changed from My C&P! X while the web 
server is running. If the server 
is running, you’ll need to stop it 
temporarily while you make your 
changes. However, most prefer-
ences can be changed remotely 
using a web browser without stop-
ping the server if the allow remote 
administration setting is enabled.

Remotely managing the My C&P! 
X web server

The server’s preferences can be 
changed from the My Clients & 
Profits! X application or remotely 
from any web browser. To remotely 
change preferences, the allow 
remote administration option must 
be checked. This setting allows 
webmasters to check and update 
the server’s preferences from 
home, a trade show, a client’s 
site—anywhere there’s an internet 
connection.

■  There is an inherent security 
risk to allowing the My C&P! X 
server’s preferences to be changed 
remotely. While the server’s preferences 
can only be changed by a web administrator 
(whose user ID and password are assumed 
to be private), there’s no guarantee that 
someone couldn’t steal the administrator’s 
account information and access the server’s 
settings. For this reason the server can’t be 
started or stopped remotely; instead, starting and stopping My Clients & 
Profits! X can only be done from the application itself. 

For better security, remote administration via the internet can be limited to 
one specific, preset IP address. The restrict remote administration option 
prevents any computer except the one with the preset IP address from moni-
toring and managing the My C&P! X server remotely. This setting ensures 
that only the designated web administrator’s computer can remotely manage 
My Clients & Profits! X However, this setting only works for a computer with 

Setting My C&P! X Preferences

Changing My C&P! preferences 
anywhere If the allow remote 
administration is enabled, web 
administrators can change the 
My Clients & Profits! X web server 
preferences from any browser.

a fixed IP address, such as a home computer connected using a DSL or cable 
modem. Laptops and computers using a dial-up modem connection have 
dynamic IP addresses that change with each new connection, so they won’t 
have the same address every time. They can’t be used for remote administra-
tion if the restrict remote administration setting is enabled.

■  For security reasons, the web server can’t be started or stopped remotely. 

To change the My Clients & Profits! 
X web server preferences

1  Choose My Clients & Profits! 
> Preferences link  from the Web 
Server Status window.

The Preferences window opens, 
displaying the My Clients & Profits! 
X web server’s current settings and 
options.

2  Make any changes, then click 
Save.

Any changes you make take affect 
instantly once the web server is 
started.

To change the My C&P! X web 
server preferences from a web 
browser

1  Open your web browser and con-
nect to My Clients & Profits! X

2  Enter your user ID and password, 
then click Go.

3  Click the Preferences link in the Web Admin section of your home page.

The web server preferences home page opens, displaying the server’s current 
settings and options.

4  Make any changes, then click Save.
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1  The always start option tells My 
C&P! X to check for hits as soon as 
it’s started. (If unchecked, My C&P! X 
won’t serve pages until the web admin-
istrator clicks the “start” button.) The 
sound bell on hits option makes My 
C&P! X beep after every hit. The dis-
able activity log option stops My C&P! 
X from tracking how people use the 
server, which improves performance by 
reducing the system’s overhead caused 
by logging. The automatically archive 
activity log every Monday purges the 
web log weekly (see page 25). 

2  Use the automatically stop option 
accommodate the nightly backup. My 
C&P! X will stop, close the database, 
then reopen the database and restart 
the web server at user-defined times. 

3  The notify webmasters of failed 
logins option e-mails the webmaster 
every time someone tries to access My 
C&P! X with an unknown user ID or 
password. The disable web accounts 
option will suspend any user who 
enters an invalid password three times. 

The My C&P! X Preferences window

The My C&P! X Preferences window

The bad password option sends an 
e-mail notification when a valid user ID 
tries to enter an unknown or incorrect 
password. 

4  The allow remote administration 
option lets web administrators monitor 
the server’s status, add web user ac-
counts, and check the server’s log from 
any web browser. If the allow remote 
administration option is checked, a 
web administrator can be restricted to 
accessing the server from a specific 
computer at a fixed IP address. To al-
low a web admin to access My C&P! X 
anywhere, leave it blank.

5  The web log server errors tracks TCP/
IP errors on the activity log. The notify 
webmaster about server errors option 
automatically e-mails the webmaster 
about server error. These two settings 
are only needed to troubleshoot server 
problems.

6  My C&P! X uses a javascript based 
file to store scripts for displaying data 
on web pages. The my_script.js file 

is normally accessed from the C&P 
web site, but can be served from your 
own site. For more information, see 
page 33.

7  The port number on which My C&P! 
X listens for hits can be changed from 
80, which is the default for web serv-
ers, to any port number.

8  Enter the name and e-mail address 
of the My C&P! X webmaster here. Web 
users can send questions, problems, 
and comments to this webmaster easily 
from links included on selected web 
pages. While there can be many My 
C&P! X web administrators, there is 
only one designated webmaster. The 
SMTP server is either the name or IP 
address of your mail server. If you don’t 
want to get automatic e-mail, leave it 
blank. 

9  This standard greeting appears on 
the introduce page whenever someone 
tries to access My Clients & Profits! X

10  The table font/size setting is HTML 
code that formats cells on CGI-gener-
ated tables, such as a list of job tasks. 
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Setting up My C&P! X Users

Only authorized My Clients & Profits! X web users can access the shop’s 
database. Any staff member, freelancer, client, or vendor can be set up as a 
My C&P! X user—all they need is a valid web account, ID, and password. 

All current Clients & Profits users can also be web users, allowing them to 
work with clients, jobs, time, and more from either their Clients & Profits ap-
plication or the My C&P! X web server. Select clients can have their own My 
C&P! X web account, letting 
them see their own jobs, costs, 
and job status (but not for other 
clients, of course). Vendors 
can be allowed to see their 
purchase orders. Also, freelanc-
ers can access their jobs, tasks, 
and deadlines. All accounts 
can be given expiration dates 
to keep users from accessing 
My C&P! X after a certain date. 
There is no guest access to My 
C&P! X.

Web users cannot create their 
own accounts online; instead, 
accounts can only be created 
by a My C&P! X web admin-
istrator. Web accounts can be 
added from the My C&P! server 
application or remotely from a 
web browser if the remote 
administration preference is 
enabled (see pages 16-17).

To view a list of My C&P! 
users

1  Choose Setup > Users, Access 
& Passwords or click the users 
button from the Server Status 
window.

The Users window opens, 
displaying the web accounts for 
existing My C&P! X users. Since web accounts are not created automatically 
when My C&P! X is first installed, the list will be empty. 

To automatically create web accounts for current C&P users

1  Choose Edit > Auto-create Web Users or click the auto-create button. 

The Auto-create Web Users window lists the shop’s current Clients & Profits 
staff members who aren’t already My C&P! X users. Some or all staffers can 

Setting up My C&P! X users

Create web accounts automatically The Auto-
create window is a shortcut for creating My 
C&P! web accounts for one or more existing 
Clients & Profits users. The window lists all 
current C&P users who don’t have access to 
My Clients & Profits! X Clicking the checkbox 
automatically creates a web account for the 
selected users.

be given access by clicking on individual user names.

2  Click on the checkbox to create a My C&P! X web account for any user, 
then click Save.

A new My C&P! X web account will be created automatically for each Clients 
& Profits selected user. The user’s Clients & Profits information is copied 

to My C&P! X automatically, so 
there’s no rekeying of their ID, 
name, and access privileges—
except for their web password. 

Passwords are required to access 
the web server. For better security, 
users can’t choose their own pass-
words; they can only be changed 
by the web administrator. All 
new user accounts are given the 
temporary password of temp. New 
My C&P! X users will enter their 
initials and the password “temp” 
until a web administrator assigns 
a permanent web password to 
each new user. To automatically 
create a random password, click 
the Create Password button. 

To add a new web user

1  Choose Edit > Add New Web 
User or click the add button.

2  Enter the web user’s account 
information and access privileges 

(see page 20). 

3  Click Save.

To edit a web user’s access privileges
 
1  From the Users window, double-click on a web user.

 2  Make your changes then click Save.

 To delete a web user’s account

 1  From the Users window, click once on a web user.

 2  Choose Edit > Delete Web User or click the delete button.
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1  Web user accounts can be added, 
edited, deleted, and printed by clicking 
these toolbar buttons. Clicking a button 
is identical to choosing an Edit menu 
command.

2  The auto-create button is a shortcut 
that creates My C&P! X web user ac-
counts for one or more existing Clients 
& Profits users. Clicking this button 
opens the Auto-Create window, which 
lists everyone who already uses Clients 
& Profits. If selected, the account in-
formation for each user will be copied 
to a new My C&P! X web user account 
automatically, including access privi-
leges. Each new user account is given 
the temporary web password of “temp”. 

3  To jump to a web user’s access privi-
leges window, enter the user’s initials 
then click the Find button.

4  My Clients & Profits! X allows 

The My Clients & Profits! X Users window

The My C&P! Users window
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different kinds of users to access the 
shop’s C&P database, including staff 
members, freelancers, clients, and 
vendors. Each web user is identified as 
a staffer, freelancer, client, or vendor. 
Since each individual web user has 
his or her own account, the My C&P! 
X user list can become very long. 
The show menu filters the user list to 
display only one kind of user at a time, 
making it easier to track who can use 
My Clients & Profits! X Choose “all” to 
display all web users.

5  The user ID and name identify each 
My C&P! X web user. Each web user 
needs a unique ID, such as initials, 
before he or she can access My Clients 
& Profits! X Existing Clients & Profits 
users are identified by the same initials 
they use in the C&P database.

6  Click the access privileges button 
to edit a web user’s access privileges. 

These privileges determine just what 
someone can see and do with My 
Clients & Profits! X

7  The user list displays all or some of 
the My Clients & Profits! X web users. 
It can contain names of staff members, 
freelancers, clients, or vendors. 
Double-click on a user to edit his or her 
access privileges.

w

y
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1  Each web user must have a unique 
ID. The ID will be used for the user 
to log onto My Clients & Profits! X if 
the web user is also a Clients & Profits 
user, then the web ID is identical to 
their C&P ID (which is usually their 
initials). The ID field is limited to 10 
characters, so a long value like an e-
mail address can’t be used as an ID.

2  Each My C&P! X user is identified 
by kind—staffer, freelancer, client, or 
vendor. This setting determines which 
pages are available to users. Clients 
have their own custom home page, 
and are limited to seeing only their 

My C&P! X Access Privileges
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jobs. Vendors can only see their POs. 
Freelancers have limited access to jobs 
and traffic.

3  Any account with the web server 
administator option enabled can start, 
stop, monitor, and manage the My 
C&P! X web server. The web server 
administrator also typically Clients & 
Profits system managers. There can be 
multiple web administators.

4  The web user’s password is assigned 
by the web administrator. For better 
security, users can’t choose their own 
passwords — or change them later. A 

w

o

i

p

user password is required. Click the 
Create Password link to automatically 
assign a random password. The pass-
word will be automatically encrypted 
when the user’s access privileges are 
saved. The user’s password can be set 
to expire, preventing access to the My 
Clients & Profits! X server after a speci-
fied date (which is a useful option for 
temporary staff). 

5  The no web access after option 
prevents a web user from accessing My 
C&P! X after a selected date. Use this 
for temporary employees or contractors 
who should only use My C&P! X for a 

a
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My C&P! Access Privileges

My C&P! X Access Privileges

limited time.

6  The web administrator can use 
the account suspended option to 
temporarily prevent a web user from 
using My C&P! A user’s web account 
is automatically suspended after 3 
bad login attempts if the disable web 
accounts after failed logins setting in 
Preferences is checked (see page 17).

7 The welcome message is an optional 
greeting that appears on each user’s 
home page.

8  The allow web access to settings 
determine which pages a web user can 
see and use. These settings only allow 
a user to see a page; what they can or 
can’t do with it is based on their access 
privileges in Clients & Profits (e.g., 
adding job tasks, a PO limit, seeing 
costs, etc.).

Selecting the clients option allows a 
web user to see the client’s account 
information as well as client contacts, 
billing information. The job tickets 
access privileges determine which 
production, estimating, and traffic 
functions are available to a My Clients 
& Profits! X web user. If a My C&P! 
user is a staff member, then his or her 
access privileges to jobs is copied here. 
Web users who are clients have no 
automatic access to jobs; instead, the 
web administrator needs to specifically 
decide which functions the user can 

see by checking on the various options. 

9  Click the All button to make all of 
the options available to the web user. 

10  Web users can be restricted to 
seeing one particular client and its 
jobs or vendor and its POs using the 
restricted to option. When a client or 
vendor number (or code) is entered 
here, the web user won’t be able to see 
any other client’s and vendor’s data. 
This option is required for web users 
who are clients or vendors. It can be a 
useful option for web users who belong 
to exclusive account teams. Client and 
vendor numbers are available for quick 
reference using the Lookup menu. 

11  Each user can have a completely 
custom home page (see page 37). 
When a custom home page is specified 
in a user’s web account, My C&P! X 
displays it instead of the standard 
home page whenever that user logs in. 
The custom home page needs to be 
created first, then selected by clicking 
on the Get Page button.
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Running the My C&P! Web Server 

Once the My Clients & Profits! X server software is installed, web service can 
be started immediately. (There is no client-side software to install and noth-
ing to set in the web browser. Anyone using a web browser can access My 
Clients & Profits! X immediately.) 

There are two steps to starting the My Clients & Profits! X web server:  (1) 
launch the My C&P! application then (2) start the web server. 

The My C&P! server application won’t start 
listening for requests, or hits, from web users 
until web service has been started. This gives 
the web administrator a chance to update the 
user list, review the activity log, and update 
preferences before web users start accessing 
the server.

■  Opening the My Clients & Profits! X ap-
plication doesn’t automatically start the web 
server unless the always start web service at 
startup option is enabled in Preferences. When 
this option is enabled, My C&P! will start 
listening for hits as soon as the server applica-
tion opens (for more information on setting 
preferences, see page 16).

■  The My Clients & Profits! X web server can 
be set to automatically close the database at 
a specified time each evening to accomodate 
the nightly backup. The web server will stop 
listening for hits, but doesn’t actually shut 
down. Instead, My C&P! waits until a specified 
time then reopens the database and restarts the server. Clicking the automat-
ically stop My C&P! for nightly backups preference sets the close and reopen 
time to 11 pm and 5 am.  The close time can’t be set before 5:00 pm or after 
12:00am. The reopen time can’t be set after 12:00 am or before 10:00 am.

To start the web service

1  Choose My Clients & Profits > Start Web Server or click the start button.

Starting the web service resets the Web Server Status window: the Today’s 
Activity list, the Connected User list, and the Hits Per Hour graph. As soon as 
web users start logging onto My Clients & Profits! X you’ll see the hits 
ref lected on this window. 

The Web Server Status window usually remains open while My Clients & 
Profits! X is running, making it easy for web administrators to monitor the 
server’s usage and performance at a glance.

To stop the web service

1  Choose My Clients & Profits > Stop Web Server or click the stop button.

Running the My Clients & Profits! X Web Server

Stopping the web service stops My Clients & Profits! X from listening for hits 
from web users. 

■  If a web user tries to access My Clients & Profits! X when it isn’t running, 
they’ll get a “a connection failure has occured” error from their web browser. 
It may take up to one minute for the browser to realize the server’s not run-
ning and show the error message.

Making changes to the My Clients & Prof-
its! X web server

The My Clients & Profits! X web server 
doesn’t have to be stopped to make chang-
es to users, preferences, or the activity 
log. All of these functions can be accessed 
without interrupting web service.

To monitor the web server’s status

If the My C&P! X Web Server Status 
window isn’t opened, choose My Clients 
& Profits! > Web Server Status. The Server 
Status window displays the server’s recent 
activity and connected users.

■  The My C&P! X web server can also be 
monitored remotely from a web browser 
if the allow remote administration prefer-
ence is enabled. This setting allows a web 
administrator to view the server status, 
activity log, user list, and preferences web 

pages from any internet connection.

To reset the My Clients & Profits! X web server

Resetting the My C&P! X server clears the Today’s Activities list, Connected 
Users list, and Hits-Per-Hour graph. It does not stop the web server or affect 
whatever work a connected user is doing. Starting the web server automati-
cally resets the server’s stats. My C&P! X only needs to be manually reset 
each morning so that the Server Status stats are cleared for the new day’s 
work—and only if My C&P! X wasn’t stopped the night before.

Looking up clients, vendors, staff members, etc.

For easy reference, lookup lists for clients, jobs, vendors, staff members, and 
more can be opened by the web administrator from the My Clients & Profits! 
X application using the Lookup menu. 

To quit My Clients & Profits! X

1  Choose File > Quit.
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1  The start and stop buttons control 
the My Clients & Profits! X web server. 
Clicking the Start button tells My C&P! 
to begin listening for requests, or hits. 
Clicking the Stop button stops the 
server, but leaves the My C&P! applica-
tion running.

2  Clicking the users button opens the 
My C&P! users window, where web user 
accounts can be added, edited, and 
deleted.

3  Click the prefs button to change the 
My Clients & Profits! X web server’s 
preferences.

4  Clicking the log button opens the My 
Clients & Profits! X activity log.

5  Click the print button to print web 
server performance and utilization 
reports.

6  Clicking the reset button clears the 
data on the Web Server Status window, 
including the day’s activities, currently 
connected users, and hits-per-hour 
graph. Use the Reset function to start a 
new set of daily statistics.

7  The database name shows the name 
and location (i.e., file server) of the Cli-
ents & Profits database which is being 
served by My Clients & Profits! X

8  The web server’s current status tells 
you what the My Clients & Profits! X 
system is doing right now.  The typical 
status is “Running” while it waits for 
requests from web users.  

9  The today’s activity list displays 
the day’s most recent hits to the web 
server. Hits, or requests from users, 
are listed chronologically, newest ones 
first. Each hit shows its date and time, 
the web user who made the request, 

and what action occured. This list can 
get very long. Clicking the Clear button 
erases the list without actually deleting 
the log entries.

10  The connected users list shows 
the names of recent web users. The 
list displays the most-recent My C&P! 
X users first. Users are identified by IP 
address. A specific user can be discon-
nected from My C&P! by clicking the 
disconnect user button, which allows a 
different user to connect to web server 
with the same IP address.

11  The hits per hour graph visually 
shows how busy the web server has 
been today. The graph charts hits per 
hour from 6 AM to 8 PM (hits after 
those hours aren’t graphed). The 
graph’s scale will change based on the 
volume of hits to the web server.

12  The current event panel shows the 
process currently being performed by 
the web server.

The My C&P! Web Server Status window

The My C&P! Web Server Status window
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The My C&P! X Activity Log

The activity log keeps track of every request, or hit, to the My Clients & 
Profits! X web server. Each hit creates a web log entry, which contains the 
date and time of the hit, the user’s ID, and what actually happened (i.e., the 
event). 

The activity log can store thousands of hits. Log entries are created instantly 
after every hit to the web server. The activity log can be searched to find 
entries for a particular day, which can then be printed.  The web log can be 
automatically archived every Monday based on a setting in Preferences to 
keep the log size man-
ageable. 

Webmasters can view the 
log any time from the My 
Clients & Profits! X server 
application to monitor the 
server’s work load. The 
log can also be monitored 
from a web browser if the 
allow remote administra-
tion option is enabled in 
Preferences (see pages 
12-13).

To view the My C&P! X 
activity log

1  Choose My Clients & 
Profits! > Web Server  Log 
or click the log button 
from the Server Status 
window.

The Activity Log window opens, list-
ing all of the web server’s log entries 
in chronological order. The entries on 
the log can be sorted by date, user, 
and event description by clicking on 
a column heading. The sort direction 
(i.e., ascending or descending) can 
be changed by clicking on the up and 
down buttons.

To find a selected day’s log entries

1  Enter a date into the find date: field then choose File > Find Log Entries or 
click the find button.

The log entries for the selected date will be highlighted in the Activity Log 
window. To print a list of these log entries, click the print button.

The My C&P! X Activity Log

To print the activity log

The Activity Log Report is a hard-copy version of the activity log window. The 
printed report shows all log entries or some entries, depending on which ones 
are selected. Log entries will be sorted on the printed report in the same way 
they are sorted on the window. 

To print the entire activity log, choose Edit > Deselect Log Entries. To print 
a selection of log entries, use your mouse to highlight the entries you wish 

to print.

1  Choose File > Print 
Activity Log or click the 
print button.

To clear the activity log

Selected entries can 
be removed from the 
activity log. While the 
activity log can hold 
over 100,000 entries, the 
number of entries that are 
displayed in the Activity 
Log window is based on 
your computer’s available 
memory. Log entries 
should be regularly 
deleted when they are no 
longer relevant or likely 
to be used. 

To clear a selection of log 
entries, use your mouse to highlight a set of entries. To clear the entire list, 
choose Edit > Deselect Log Entries.

1  Choose Edit > Clear Log Entries or click the clear button.

To export log entries

Selected entries can be exported from the activity log into a tab-delimited 
text file. This text file can then be opened by Microsoft Excel, FileMaker 
Pro, Access, and any other spreadsheet or database for analysis. Exporting is 
an ideal method for storing old sets of log entries when they are no longer 
needed in the activity log.

■  Exporting doesn’t clear log entries. If you don’t want to keep exported 
entries in the activity log, click the Clear button to delete the selected log 
entries.

Sorting the activity log  Log entries for 
every hit to the My Clients & Profits! X 
server is recorded in the Activity Log. 
Log entries can be sorted by date, 
user, or by what  appened by clicking 
when, user, or event column headings.



21The My C&P! X Activity Log 

To export a selection of log entries, use your mouse to highlight a set of 
entries. To export the entire list, choose Edit > Export Log Entries.

1  Choose Edit > Export Log Entries or click the export  button.

To remotely monitor the activity log

The My Clients & Profits! X web server activity log can be monitored re-
motely from any internet  
connection using a web 
browser. This ability lets 
My C&P! X web admin-
istrators monitor the 
server’s usage and per-
formance when they’re 
outside the office—from 
home, an airport, a trade 
show, or a client’s office. 

The allow remote 
administration option 
in the My C&P! X web 
server’s preferences 
must be checked before 
the log can accessed 
from a browser. The view 
activity log function 
appears as a link on 
the web administrator’s 
home page. 

■  Only web adminis-
trators can remotely 
monitor and manage the 
My Clients & Profits! 
X server from a web 
browser.

To automatically ar-
chive the web 
log every Monday

The automatically 
archive activity log every 
Monday option tells My Clients & Profits! X to export the week's web log 
every Monday morning, then start a brand-new log for the week. This setting 
keeps your web log's size manageable (a busy shop with lots of web users 
could have a 10,000+ entry web log within months). The exported logs are 
automatically dated and stored in the same folder as your My C&P! X web 
server. 

These tab-delimited text files can be opened in Excel, FileMaker, Access, or 

any text editor. To keep all of the web log entries together in your database, 
leave this preference unchecked. 

1  Click the Preferences button.

2  Check the automatically archive activity log every Monday option.

3  Click Save.
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Printing My C&P! X Server Reports

Server reports are your best source of up-to-date statistics on the My Clients 
& Profits! X web server’s usage. These reports analyze the My C&P! activity 
log to determine the most-active users, most-popular web pages, and more. 
Web server reports can be printed for any range of dates, letting web admin-
istrators compare the server’s performance and utilization for any period of 
time.

General reports are lists of users and other basic information about the My 
Clients & Profits! X 
server. These reports 
provide hard-copy 
printouts of staff 
members, freelancers, 
clients, and vendors 
and what they can 
do with My Clients & 
Profits! X

Performance reports 
look at the big 
picture—raw numbers 
of hits by days of the 
week, time of day, 
and week vs. week. 
These reports help web 
administrators track 
the busiest times for 
My Clients & Profits! X, 
which helps them bet-
ter manage the system. 
The “hits” report series 
can be printed for one 
day, one week, or any time period. This 
exibility allows web administrators to 
see more or less data on reports.

Utilization reports highlight the 
most and least active users, as well 
as the most- and least-used web 
pages. These reports help web administrators determine which 
parts of My Clients & Profits! X are useful and productive to staff members, 
freelancers, clients, and vendors.

■  Each of the server reports has its own unique purpose. You may not need 
everyone to help web administrators manage the server. Instead of printing 
every report, experiment with each report (and its various options) to see 
which one gives web administators the best information they need to stay on 
top of the server’s performance.

Who’s using what?  My Clients & 
Profits! X reports analyze how the 
server is being used for a day, week, 
month, quarter, or any period of time 
based on entries saved in the server’s 
activity log.

To print server reports

Most of the web server reports are based on entries in the activity log, which 
are selected for a range of dates. Entering a range of dates will search the log 
and analyze the entries for that time period. 

1  Choose File > Print Server Reports, or click the print from the Web Server 
Status window.

2  Select the kind of 
report you wish to print 
(e.g., General, Perfor-
mance, or Utilization).

3  Make your report 
selections.

4  Click Print.

Server reports that show 
a broad time period, 
such as a month or 
quarter, will take longer 
to print than reports 
based on a day or week, 
since there are more log 
entries to analyze.

Tips for printing My 

C&P! X server reports

■ Use the Peak Usage report to keep track of the My Clients & Profits! X web 
server’s busiest times. Web administrators can use this analysis to better plan 
maintenance and other downtime, and well as determine whether the server 
hardware is adequately handling the work load.

■   Since web users can’t choose or change their own passwords, it’s up to 
the web administrator to maintain them. The Account/Password Expiration 
report lists accounts and passwords that are emiently expiring within the 
next 30 days and need attention. If the web administration doesn’t update 
these expiration dates, the web users will suddenly lose access to My Clients 
& Profits! X This report should be printed monthly.
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My Clients & Profits! X Server Reports

Web Users - Staff Members

Web Users - Freelancers

Web Users - Clients

Web Users - Vendors

Account/Password Expirations

Hits by Day

Hits by Time

Hits by Week

Peak Usage

Errors

Most-Active Users

Least-Active Users

Most-Popular Pages

Least-Popular Pages

User Connections

The Web Users report lists staff members by user ID. This report shows each user’s last ac-
cess date and other account information.

This version of the Web Users report shows only users marked as “freelancers” in the Users 
list. Freelancer users can have the same access privileges as staff members.

This version of the Web Users report only shows individuals who work for the shop’s clients, 
displaying each user’s account information. Users are grouped by client number.

This version of the Web Users report displays web users who work for the shop’s vendors.

This report lists expiring web accounts. The report has two parts: one for expiring accounts 
and another for expiring passwords. Since users can’t change passwords themselves, web 
administrators can use this report to update old passwords.

This report analyzes users requests, or hits, for each day of a selected week. This report 
calculates the total hits per day to help web administrators track the server’s volume. 

The Hits by Time report analyzes how web users used My Clients & Profits! X throughout the 
day. The report totals up hits by hour for any range of dates.

The Hits by Week report compares hits to the My Clients & Profits! X web server week-by-
week for any selected period of time. The report helps analyze My C&P! usage over a longer 
time frame.

The Peak Usage report calculates the web server’s busiest times based on the number of 
hits per hour for a range of dates.

The Errors report analyzes the web server’s activity log for error log entries. Web administra-
tors can use this report to monitor the number, frequency, and type of errors occuring in My 
C&P!

The Most-Activity report displays the users with the most connections to the My C&P! X 
server.

The Least-Activity report displays web users who have the fewest connections to the server.

The Most-Popular report analyzes the activity log for the most frequently used web pages.

The Least-Popular report displays pages with the least number of hits from web users.

The User Connections report lists connections to the My C&P! X web server by IP address.

General

Utilization

Performance
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Remotely Managing My C&P!

Parts of the My Clients & Profits! X web server can be monitored and man-
aged remotely from any internet connection using a web browser. This ability 
lets My C&P! X web administrators monitor the server’s usage and perfor-
mance when they’re outside the office—from home, an airport, a trade show, 
or a client’s office. 

The remote administration functions include server status monitoring, 
viewing the activity log, setting the My C&P! X web server’s preferences, 
adding new web users, and 
updating web user access 
privileges. These functions 
appear as links on the web 
administrator’s home page. 
Remote administration 
has no affect on regular 
My C&P! X users, and is 
completely optional. All 
changes you make take 
affect immediately.

■  Only web adminstrators 
can remote monitor and 
manage the My Clients 
& Profits! X server from a 
web browser. Any web user 
who is a staff member (i.e., 
not a client, freelancer, or 
vendor) can become a web 
administrator by checking 
the web server administra-
tor option in the user’s 
access privileges window.

Remote administration is 
not a standard option, so 
must be enabled in the My 
C&P! X preferences. Once 
enabled, any My C&P! X 
user with web administra-
tor privileges can connect 
to the server, monitor it, 
and make changes. 

Restricting remote administration

My Clients & Profits! X features 
a special high-security option to 
prevent unauthorized people from remotely monitoring and changing the 
web server. The restrict remote administration to IP address option appears 
when the allow remote administration option is checked. This security option 
restricts My Clients & Profits! X from being remotely administered by only 

one specific computer based on its IP address. If an IP address is entered 
here, only the computer that has this address will be allowed to monitor and 
manage My Clients & Profits! X. My C&P! X can still be accessed from any 
other addresses, but the remote administration links will not appear on your 
home page. This setting effectively restricts My C&P! X from being monitored 
and managed from an unknown computer—and more than one web adminis-
trator, since it allows for only one IP address. It should be used at sites where 
security is more of a concern than easy accessibility by web administrators.

■  This option will only 
work for computers with 
fixed IP addresses, such as 
the ones on your LAN. It 
won’t work for web admin-
istrators who use a laptop 
and a dial-up modem con-
nection to My C&P! X, since 
its IP address changes with 
each new connection.

To enable remote admin-
istration

1  Click Setup > Prefer-
ences.

2  Click on the allow re-
mote administration option 
to select it.

3  If the restrict option is 
to be used, enter the web 
administrator’s IP address; 
otherwise, leave it blank to 
allow any web administra-
tor to remotely control My 
C&P! X from any computer.

4  Click Save.

Once the allow remote 
administration option is 

selected, a web administrator can monitor the server from a browser im-
mediately.

To remotely monitor the server’s status

1  Open your web browser then log onto My Clients & Profits! X with your 
user ID and password.

Your customized home page appears, which now includes links for remote 

Remotely Managing My C&P X!

Monitoring the server’s status The My 
Clients & Profits! X server status web 
page shows who is using My C&P! as well 
as the day’s hits.
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server administration: server status, users, activity log, and preferences. 

2  Click on any admin link to monitor or manage the server.
To monitor the server’s status

1  Click on Setup > Web Server Status.

The server status link opens the My C&P! X Web Server Status page (see 
above). This page is 
the web-page equiva-
lent of the My C&P! X 
Server Status window. 
It shows the currently 
opened database, the 
server’s current sta-
tus, and the date and 
time the server was 
started. The page also 
lists the server’s con-
nected users (listed 
in order of last access 
to the server) and the 
day’s activities (i.e., 
log entries).

To view a list of My 
C&P! X web users

1  From the home 
page, click on the 
Users link.

The users link opens 
the My C&P! X Users 
page, which lists your 
web user accounts. 
User accounts are 
listed in alphabetical 
order by ID. Clicking on an account 
lets you edit the user’s access 
privileges. 

To edit a web user’s access privi-
leges

1  From the Users web page, click on 
the user’s initials.

The user’s access privileges web page opens. There are limits to what user 
account information can be seen and changed remotely. For example, the 
user’s password can’t be changed here; for security reasons, it must be 

Remotely Managing My C&P X!

Monitoring the server’s log The My 
Clients & Profits! X activity log web 
page shows all of the server’s hits in 
chronological order, newest ones first. If 
the log web server  errors preference is 
enabled, any kind of TCP/IP error will be 
logged and displayed in red. This setting 
should be used for troubleshooting only 
since it generates a large number of web 
log entries.

changed from the My C&P! X application itself. 

2  Make your changes, then click Save.

To add a new web user account

A new user account can also be created remotely, which can be 
convenient for webmasters who aren’t always near the My C&P! X server.  

1  From the Users 
web page, click on 
the Add New User 
link.

The user’s access 
privileges web page 
opens.

2  Enter the new 
web user’s account  
information.

3  Click Save.

The new user can 
access My Clients & 
Profits! X using their 
ID and password im-
mediately.

To view the server’s 
activity log

1  From the home 
page, click on the 
Activity Log link.

The activity log link 
opens the Log web page, which lists the server’s hits in chronological order 
(newest ones first). This page can take several minutes to display if the log is 
large. 

To change the web server’s preferences

1  Click Setup > Preferences.

The preferences link opens the My C&P! X preferences web page. Since 
preferences can’t be changed from the My C&P! X application while it’s run-
ning, this web page is the only way to change preferences without stopping 
the server. 

2  Make your changes to the server’s preferences, then click Save.
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Appendix A: Security Issues

My Clients & Profits! X was designed to offer reasonable security to the 
shop’s Clients & Profits database, while making it available to the widest 
number of users. It is a custom, proprietary HTTP server, so can’t be accessed 
anonymously like other web servers. 

The My Clients & Profits! X server itself contains no company data. All of the 
data it uses is stored in the Clients & Profits database on your file server. If 
My C&P! can’t access your file server for any reason, then it can’t serve data 
to web users.

The My C&P! web pages themselves contain no company data, either. Pages 
contain tags (called OMFLDs; see page 30) that are used by the My C&P! CGI 
to access records from the shop’s Clients & Profits database. A web page only 
shows actual data when it is processed by the My Clients & Profits!’s CGI, 
which can only happen if someone logs on with a valid user ID and password. 
If someone copies an HTML page from My C&P!, they will only see the page’s 
OMFLDs. This effectively prevents spiders and bots from indexing My Clients 
& Profits! X

The server does not support SSL, so cannot establish secure encrypted 
connections between users and the web server. For this reason, My Clients 
& Profits! X offers only limited access to your accounting data. There is no 
access whatsoever to anything financial, such as checks, client payments, or 
the general ledger. 

My Clients & Profits! X contains many built-in security features which, when 
used together with responsible management practices, help ensure that 
confidential company data stays private. 

My Clients & Profits! X’s security features include:

Starting My Clients & Profits! X  Only Clients & Profits system managers 
can configure the C&P database for My Clients & Profits! X, set up web users, 
then start the web server.

Individual user accounts  While My Clients & Profits! X can be accessed 
from any internet connection, it is not a publicly available server. It is only 
accessible to staff members, freelancers, clients, and vendors who are autho-
rized My C&P! web users. Each individual person has their own web account, 
including people who work for the shop’s clients and vendors. Users can’t 
create their own accounts; instead, they must be set up by the My C&P! web 
server administrator. User accounts can be set to expire at a selected date.

User passwords  Each web account has its own password. Passwords are not 
defined by the user; instead, they must be assigned by the My C&P! X web 
administrator (“webmaster”). User passwords can be set to expire at certain 
dates to help keep passwords from being circulated. Passwords are stored in 
the Clients & Profits database as encrypted data.

Access Privileges  The functions that a web user can see and do are based 
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on their My Clients & Profits! X access privileges. Each web user can be 
given access to clients, jobs, time cards, expenses, etc. by the My C&P! web 
administrator. Clients and vendors have limited access to the database, while 
staff members and freelancers can add jobs, edit estimate, etc. based on their 
access privileges to Clients & Profits.

No guest access  There is no temporary “guest” access to the My Clients & 
Profits! X web server. Unlike other web sites, anonymous users can’t create 
their own My C&P! X account and get temporary, limited access to the sys-
tem. Instead, user accounts can only be created and managed by a My C&P! 
X web administrator.

Cookies control user access  Cookies must be enabled on the users’ browsers 
to access the My C&P! web server. When a user successfully logs onto My 
C&P!, a cookie is automatically set in their browser that lasts for 24 hours. 
The user can then repeatedly access My C&P! X web pages during that period 
without reentering their ID and password. The cookie’s expiration date can 
be changed (for example, to a week instead of one day) by changing the 
Javascript in the introduce.htm page.

No bookmarks  Web users can only access My Clients & Profits! X from the 
“introduce yourself” page. This ensures that My C&P! X knows exactly who 
has accessed every web page. If a user bookmarks any My C&P! X page (other 
than the Introduce Yourself page) the server will open the introduce page 
instead.

Restrictions to client, vendor accounts  A web user can be restricted to 
seeing only one client’s account information, jobs and costs as part of their 
access privileges. The same restriction can be made to web users who are 
vendors; they are limited to only seeing their POs. This option can be used 
with staff members and freelancers, as well as clients. Vendors can’t access 
client information in any way, and clients can’t see vendor data.

Failed login notification  A notify webmaster of failed logins via e-mail prefer-
ence (see page 17) automatically sends an alert via e-mail to the My C&P! X 
webmaster whenever someone tries to access the web server with an invalid 
user ID or password. An entry is also made in the server’s web log. 

Bad password notification  My Clients & Profits! X will notify the webmas-
ter via e-mail whenever a web user tries to log onto the server with a bad 
password.

3 bad passwords suspend web accounts  The optional disable web accounts 
after 3 bad passwords preference will automatically suspend a web account 
if the user enters a bad password three times in a row. The user will see an 
error page explaining why their account has been suspended, and the My 
C&P! X webmaster will be notified via e-mail. The account can be reactivated 
from the My C&P! X user access window (see page 20) or remotely from the 
user access web page. 
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All hits are logged  The activity log tracks all hits to the My Clients & Profits! 
X web server. For faster performance, logging can be stop by enabling the 
disable activity log preference—but then you’ll have no idea of who’s using 
My Clients & Profits! X and what they’re doing.

Users are tracked by IP address  The My C&P! Server Status window shows 
the IP address of every current and recent web user, helping webmasters 
track down who’s using the server. If a user who’s connected to My C&P! logs 
in from a different computer, the new IP address replaces the original one. 

Only web administrators can remotely monitor My C&P! X. Unless the web 
server administrator option is enabled for a web user, he or she won’t be able 
to remotely monitor or manage the My C&P! web server.

Remote administration is an option  If the allow remote administration 
preference is unchecked, the home page links for server status, users, activity 
log, and preferences are not available. This prevents anyone outside the of-
fice from monitoring the My Clients & Profits! X server.

Remote administration can be limited to a preset IP address  The restrict 
remote administration preference allows a web administrator to remotely 
monitor and manage the My Clients & Profits! X server from a single speci-
fied IP address. If anyone else tries to remotely administer the server from a 
different computer they will be rejected.

Security Tips for My Clients & Profits! X

■  Don’t let users share the same web account.

■  Use long passwords of random characters and number 
instead of recognizable names, words or phrases.

■  Use the automatic e-mail notification for errors and bad 
logins.

■  Change web user passwords frequently.

■  Check the web log for excessive or suspicious use by particu-
lar users

Backups and Security

The web server can be configured to stop and start at speci-
fied times to allow nightly backups of the database, though 
the program does not actually quit. If the program is quit for 
any reason (e.g., restarting the server to install updates), it 
will have to be manually restarted afterwards. This cannot be 
automated because it would require storing login information to 
the database, which would be a security vulnerability.

While it may possible to use macro/automation software to log 
in automatically, Clients & Profits does not provide any support 
for this. 
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GIFs  31
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H
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